Router On A Stick

Da Wiki-itsos.

ROUTER ON A STICK

COS’É?

“Router on a stick” è il nome che si dà ad un router che ha il compito di far comunicare delle vlan diverse usando un’interfaccia in trunk su cui avviene il traffico delle vlan interessate.

PERCHÉ SI USA?

Il traffico tra le diverse vlan potrebbe avvenire anche connettendo le diverse interfacce del router a diverse porte dello switch su vlan diverse, ma il sistema non è pratico ed è costoso. Perciò si ricorre all’uso della configurazione in trunk.

SCHEMA LOGICO SU PACKET TRACER

OnAStick 1.png

CONFIGURAZIONE DEGLI IP DEI COMPUTER

Computer 1: IP= 192.168.1.4 SUBNET=255.255.255.0 GATEWAY=192.168.1.1

OnAStick 2.jpeg



Computer 2: IP=192.168.2.4 SUBNET=255.255.255.0 GATEWAY=192.168.2.1

OnAStick 3.jpeg

CONFIGURAZIONE DELLO SWITCH

Per configurare lo switch bisogna collegarlo a uno dei due computer attraverso un cavo seriale. Sul computer a cui è collegato bisogna avviare putty digitando da terminale il comando “sudo putty” e, quando si apre la finestra dell’applicazione, selezionare la voce serial. Una volta entrati nel terminale dello switch, usare i seguenti comandi:

switch9f8796# configure terminal
switch9f8796(config)# vlan 2 // viene create la vlan 2
switch9f8796(config)# vlan 3  //viene create la vlan 3
switch9f8796(config)# end
switch9f8796# show vlan // vengono mostrate le vlan presenti nello switch
switch9f8796# configure terminal
switch9f8796(config)# interface FastEthernet 0/2 //per entrare a modificare l’interfaccia della porta Fastethernet 0/2 che è la porta a cui è collegato il primo computer
switch9f8796(config-if)# switchport mode access // serve per configurare la porta in access e non in trunk
switch9f8796(config-if)# switchport access vlan 2 //aggiunge la fa0/2 alla vlan 2
switch9f8796(config-if)# exit
switch9f8796(config)# interface FastEthernet 0/3 //per entrare a modificare l’interfaccia della porta Fastethernet 0/3 che è la porta a cui è collegato il secondo computer
switch9f8796(config-if)# switchport mode access// serve per configurare la porta in access e non in trunk
switch9f8796(config-if)# switchport access vlan 3//aggiunge la fa0/3 alla vlan 3
switch9f8796(config-if)# exit
switch9f8796(config)# interface FastEthernet 0/4//per entrare a modificare l’interfaccia della porta Fastethernet 0/4 che è la porta a cui è collegato il router
switch9f8796(config-if)# switchport trunk allowed vlan add 2-3 // serve per consentire alle vlan 2 e 3 di scambiare informazioni con la configurazione in trunk tramite questa porta.
switch9f8796(config-if)# end




CONFIGURAZIONE DEL ROUTER

Per configurare il router bisogna collegarlo a uno dei due computer attraverso un cavo seriale. Sul computer a cui è collegato bisogna avviare putty digitando da terminale il comando “sudo putty” e, quando si apre la finestra dell’applicazione, selezionare la voce serial. Una volta entrati nel terminale del router, usare i seguenti comandi:

Router# configure terminal
Router(config)# interface FastEthernet 0/0 //entrare nelle configurazioni di interfaccia della fa0/0 che è la porta a cui non cè collegato niente
Router (config-if)# no ip address  // non assegna nessun ip address alla porta
Router(config-if)# shutdown //la porta viene spenta 
Router(config-if)# duplex auto // viene impostata come automatica la modalità duplex (sia le informazioni da router a switch sia quelle da switch a router passano nello stesso cavo.)
Router(config-if)# speed auto // viene impostata come automatica la velocità di trasmissione
Router(config-if)# exit
Router(config)# interface FastEthernet 0/1 //entrare nelle configurazioni di interfaccia della fa0/1 che è la porta a cui è collegato lo switch
Router (config-if)# no ip address// non assegna nessun ip address alla porta
Router(config-if)# no shutdown //la porta rimane accesa
Router(config-if)# duplex auto // viene impostata come automatica la modalità duplex (sia le informazioni da router a switch sia quelle da switch a router passano nello stesso cavo.)
Router(config-if)# speed auto // viene impostata come automatica la velocità di trasmissione
Router(config-if)# interface FastEthernet 0/1.1 //impostare una sottointerfaccia della fastethernet 0/1
Router(config-subif)# encapsulation dot1Q 2 //  per impostare l'encapsulation dot1Q. 2 è il numero di VLAN associata a questa subinterface. 
Router (config-subif)# ip address 192.168.1.1 255.255.255.0 // associa alla subinterface in questione un ip ( gateway del primo computer) e una subnetmask
Router(config-subif)# exit
Router(config-if)# interface FastEthernet 0/1.2 // impostare la sottointerfaccia della fastethernet 0/1
Router (config-subif)# encapsulation dot1Q 3 // per impostare l'encapsulation dot1Q. 3 è il numero di VLAN associata a questa subinterface. 
Router (config-subif)# ip address 192.168.2.1 255.255.255.0 // associa alla subinterface in questione un ip ( gateway del secondo computer) e una subnetmask
Router (config-subif)# end

Bisogna creare una subinterface per ogni VLAN.


VERIFICARE LA COMUNICAZIONE TRA I PC

Avendo svolto tutti I passaggi correttamente, i due computer, anche se su 2 vlan e su due reti diverse, riescono a comunicare.

tech@lab121pc23:-~$ ping 192.168.1.4
64 bytes from 192.168.1.4: icmp_seq=17 ttl=63 time=1.55ms
64 bytes from 192.168.1.4: icmp_seq=20 ttl=63 time=1.53ms
64 bytes from 192.168.1.4: icmp_seq=19 ttl=63 time=1.45ms
64 bytes from 192.168.1.4: icmp_seq=18 ttl=63 time=1.41ms
64 bytes from 192.168.1.4: icmp_seq=20 ttl=63 time=1.46ms
tech@lab121pc24:-~$ ping 192.168.2.4
64 bytes from 192.168.2.4: icmp_seq=52 ttl=63 time=1.60ms
64 bytes from 192.168.2.4: icmp_seq=47 ttl=63 time=1.58ms
64 bytes from 192.168.2.4: icmp_seq=50 ttl=63 time=1.59ms
64 bytes from 192.168.2.4: icmp_seq=49 ttl=63 time=1.55ms
64 bytes from 192.168.2.4: icmp_seq=51 ttl=63 time=1.57ms